Direct Banking Refund Update - TD and CIBC Bank Updates

Incident Report for Property Vista and Vida Software

Update

We are continuing to monitor for any further issues.
Posted Aug 27, 2025 - 09:47 EDT

Monitoring

TD Update: Today TD bank has confirmed all payments will be returned within the next two business days.

CIBC update: CIBC has confirmed all payments up to July 27th and August 4, 5 were returned back to customers. BMO is assisting CIBC with the payments in between those dates.
Posted Aug 27, 2025 - 09:05 EDT
This incident affects: Property Vista Property CRM (Property Vista CRM).