Direct Banking Refund Update

Incident Report for Property Vista and Vida Software

Update

We are continuing to monitor for any further issues.
Posted Aug 28, 2025 - 17:28 EDT

Update

4:00 pm Update - There are currently no new updates on Direct Banking as of this afternoon - Additional update will be made on 8/28/2025
Posted Aug 27, 2025 - 16:59 EDT

Monitoring

BMO has refunded all Financial Institutions however CIBC is still working through the backlog (some refunds were already issued). Originally, CIBC was going to start refunding on Friday, Aug 22 however due to backlog it is delayed. Property Vista is awaiting a more formal time on when we can expect this to be completed by CIBC. Property Vista is also awaiting a confirmation from TD Bank on when they will begin the reimbursement process. This date will be announced here.
Posted Aug 26, 2025 - 14:08 EDT
This incident affects: Property Vista Property CRM (Property Vista CRM).