Call Routing Problems

Incident Report for Property Vista and Vida Software

Resolved

This incident has been resolved.
Posted Jul 26, 2025 - 14:58 EDT

Update

We are experiencing an issue with our phone service - our team is investigating and expect a resolution shortly
Posted Jul 26, 2025 - 14:01 EDT

Investigating

We are currently investigating this issue.
Posted Jul 26, 2025 - 13:59 EDT
This incident affected: Vida - Lead Managing (Vida - Voice Calls, North America).